Secure Endpoint

Secure Access

System Requirements

Before you install Absolute, verify that your computer meets or exceeds the minimum system requirements.

Secure Endpoint Agent Secure Endpoint Console Secure Endpoint Language Support
  • Windows 11 (64 bit)
  • Windows 10 (32 & 64-bit)
  • Windows 8.1 (32 & 64-bit)
  • macOS 10.15, 11, 12 and 13 (Intel and Apple M1, M2 based Mac devices)
  • ChromeOS and ChromeOS Flex (requires Google Admin Console)
  • Internet connection
  • Microsoft Edge (Windows)
  • Google Chrome (Windows and Mac)
  • Safari (Mac)
  • English
  • French
  • German
  • Italian
  • Spanish
  • Japanese
  • Korean
  • Portugese
  • Chinese (Traditional and Simplified)
Product Supported Desktop Operating Systems
(and Product Version)
Supported Handheld Operating Systems
(and Product Version)
Language Support
Secure Access Client
  • macOS for ARM (v12.50 and later)
  • macOS 10.14 and later (v11.0 and later)
  • Windows 11 (v12.50 and later)
  • Windows 10 64-bit Pro and Enterprise only (v10.71 and later)
  • Windows 10 32-bit Pro and Enterprise only (v10.71 and later)
  • Windows on ARM (v12.50 and later)
  • Windows 8.1 64-bit (v10.10 to 12.5x)
  • Windows 8.1 32-bit (v10.10 to 12.5x)
  • iPad, iPhone
    iOS 12.1 and later (v12 and later)
  • iPad, iPhone
    iOS 7.1 and later (v10.50 and later)
  • Android 6.0 and later (v10.0 and later)
  • Android for Work (v11.0)
  • Samsung Knox (v11.0)
  • English
  • Japanese
  • French
  • Italian
  • German
  • Spanish
Secure Access Server
  • Windows Server 2019 (v11.70 and later)
  • Windows Server 2016 (v11.04 and later)
  • Windows Server 2012 R2 (v10.10 to v12.0x)
  • Windows Server 2012 (v10.0 to v11.0)
 
  • English
  • Japanese
Financial Services